суббота, 8 февраля 2014 г.

На полях Qt4: недостатки от слова «недо»

Начал баловаться с qtbindings. Это не то же самое, что QtRuby, а его более актуальный форк. Во всяком случае, qtbindings доступны для Ruby 2.1, а не застряли на 1.9... Впрочем, суть и принципы работы с библиотекой от этого не меняются. В контексте данного поста существенно, пожалуй, только то, что я имею дело с чистым Qt4 без расширений KDE, доступ к которым предоставляется пакетом korundum, как раз и существующим только для Ruby 1.9.

Для начала хочу сказать, что в целом фреймворк Qt4 мне весьма понравился — есть в нем какое-то чувство стиля и продуманность. Однако кое-чего не хватает по мелочи (всё нижесказанное относится именно к Qt как таковому, а не его связке с Ruby):

суббота, 1 февраля 2014 г.

RDot 1.1.1.7

Продолжаю медленно и печально допиливать совместимость с новыми версиями Ruby. Исправлены проблемы с 2.1, правда, откуда-то взялась двойная связь между Object и Kernel. Буду разбираться.

Однако, похоже, надо снова все рефакторить — с ходу уже с трудом вникаю в собственный код, а значит, логика его недостаточно ясна...