четверг, 25 июля 2013 г.

Ruby 2.0 и мои проекты

RDot работает для кода со старым синтаксисом, новые возможности требуют доработки напильником. В ветке 1.0.x такой доработки не будет, можно считать ее привязанной к Ruby 1.9, ветка 1.1–1.2 будет совместима как с 1.9, так и с 2.0, более поздние версии — только 2.0.

ppRuby на данный момент с Ruby 2.0 не работает. Судя по всему, опять поменялись внутренние константы... Предстоит бурный рефакторинг с выходом, надеюсь, на стабильную ветку.

Всякие мелкие гемы буду проверять и корректировать по ходу дела.

Комментариев нет:

Отправить комментарий